My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Inexplicable major drop in FPS

The steam client (windows) just updated, and now the game launcher commonly crashes. If the game loads properly, it runs at around 3 (yes, three) FPS while using 100% of the GPU. I was getting approximately 45 FPS before. Settings have not changed. The only thing different between now and this morning is the steam update. I have checked other games and they perform fine. I assume there must have been some sort of miscommunication between the game client and the steam update. The game is currently unplayable.

Update - I’ve determined that steam is not the issue by deleting the game, uninstalling steam, and reinstalling the game using the direct client instead of steam. However, my fps remains unplayably low. Again, I have not made any changes to settings, and the FPS for all other games remains normal. Please advise whether there are any other steps I can take to remedy this issue.

Im having problems like this. I dont know about FPS numbers or anything, but the game used to be super smooth and now after the update patch its almost unplayably choppy. I tried a full uninstall and reinstall of last epoch to no avail.

Sorry to hear that. What’s strange is that the new patch worked fine for me until today. Literally the only change was that the steam client updated, which I’ve since ruled out as being the source of the issue. I’m flabbergasted at this problem since I can’t determine its source. It’s only this game, and it doesn’t get better no matter how many times I reinstall and uninstall. At this point, I’m tempted to just reinstall windows and start completely fresh. Hopefully a developer will jump on this thread so shed some light on the issue.

I wouldn’t go that far unless you know you have other issues… Rather make sure all your drivers, system patches etc are updated first…

The devs are probably going to ask you for diagnostic files etc… here is a link to what they are likely to need.

Sorry about this! As a next step I would recommend deleting your graphics settings file so that the game creates a fresh copy when you restart, just in case.

If that doesn’t help, please upload your log files and system information so we can look into this further.

Thanks!

Hi there - thanks for your response. I tried deleting the .ini graphics file, but the only difference it made was a much longer initial launch. Once launched, the problem persisted. Should I also delete the backup file of the .ini?

Here are the .log files Player.log (8.6 KB) Player-prev.log (41.0 KB)

Here is the DxDiag info:
DxDiag.zip (15.2 KB)

having the same issue last time i played month or 2 ago got around 50 fps, now 10 or so standing still doing nothing and choppy

Are you also having low FPS in the launcher? My launcher takes forever to load, and it’s incredibly laggy. It also flashes back and forth between the desktop and the loading screen multiple times during launch, which never happened before.

I deleted the graphics file. It didn’t help. Also tried updating windows and my graphics drivers as well as a full LE reinstall. This really sucks, I can’t play the game anymore :frowning:

DxDiag.txt (78.3 KB) Player.log (88.9 KB) Player-prev.log (87.2 KB)

Any updates on this problem? I’m still unable to play the game. Been playing Grim Dawn for the last week on almost max settings with no issues.

I think this is what is happening to me as well. I just bought the game yesterday and cannot play it like this. From the loading screen, the purple swirl and background lights stutter and there is a delayed response to anything I click or type. Once I create a character, I cannot understand a word of the opening cinematic and it looks more like a static slide show.

I have tried all kinds of graphics settings. I tried installing and launching from Steam and directly from LE. My PC specs, updates and internet speed are all great and similar games work without this problem. I emailed support with my file last night and am waiting for a reply.

I was really looking forward to starting this game. It looks great when other people play it, so I know it doesn’t have to be this bad. I chose this game over some others I was considering, so I hope this company I’m now supporting decides to support me back!

Sorry to hear it. Sounds very similar to what I’m experiencing. So far, I’m extremely disappointed with LE’s response to this problem. I really enjoyed the 50 hours or so that I put into the game, but it’s been almost two weeks since I’ve heard anything from the devs regarding this game-breaking issue. Good luck, you may have picked the wrong game.

FWIW, I’ve been playing Grim Dawn ever since this issue occurred, which I would highly recommend.

Thanks, I still haven’t received a reply to my support email, but I will update this thread when/if I do.

I haven’t lost all my patience yet, so I’m still cautiously optimistic that they will fix it for us soon. In the meantime, I will be on the lookout for a good Grim Dawn sale along with some other ARPGs I haven’t played yet.