My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Downloading problems with regular Launcher (non steam version)

Hi, I just tried to update the game to 0.7.7 (from 0.7.6), and this happens in a loop : https://gyazo.com/3dff04ede8686ca5a276f402b1356644 => Low downloading speed although speed starts normally the first few minutes.

I already tried to relaunch the launcher several times, reboot my computer and it’s still the same. My network connection seems to be fine too after a speed test.

You can find joined with this post the launcher log and output log files (output will be on mediafire link, as it seems to be too huge to be uploaded here), as Hackalöken asked me to do on Discord.

Region is Europe, France to be exact.

Thank you for your help by advance!

launcher-log.txt (21.4 KB)
http://www.mediafire.com/file/le1bz4t9tqy8vtz/output_log.txt/file

Hey there!

Could you let us know if this has improved for you?

Additional data centres are now in use now in Europe. If a download is ongoing, you’ll need to restart the Launcher to notice any improvement. The download will continue from where it is currently. (It will show as 0% complete, however the total download size will be smaller.)

Just relaunched, still the same ^^’ Damn this is really weird! Sorry to bother you with that kind of bug, if that doesn’t improve that’s not a big deal, will wait 3 days to play :blush:

Hrm, I’m very sorry to hear that.

As a workaround, you could install Last Epoch through Steam instead.