My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Stuttering/ Low frames/GPU running high

Since the latest patch (after the skill reveal) i’ve had some tough problems with LE performance wise to the point its only playable at the lowest settings and low resolution. Bloom effects, player lights etc. Not sure what is causing it, i talked to a few others and we are all running 2080s. Not sure what happened.

Much love, hope this gets sorted out.

  • BzerkiN

I haven’t tried LE since I bought the pack earlier this year, so I don’t have a perfect frame of reference as to how performance was.

That said the performance currently is near unplayable. With high settings, 3440x1440, I can’t keep stable frames. We’re talking 40-50, if no mobs are on the screen and it’s just me, not moving. Any sort of fight will dip it into the 20’s. If I go as low as possible on every setting I might be 75 in town. Changing resolution doesn’t seem to help these fps issues.

Running an i7 8700k at 5ghz, 2080ti, 32g system ram.

Also just to compare, I reach my monitors cap of 180 fps in POE with everything on ultra, and it might dip down to 100-110 during the biggest fights.

This game feels like it could be really fun, loving the skill and passive systems so far, just hope to see these performance issues ironed out.

It looks to me like it has something to do with the resolution. I get smooth everything if I’m at anything less than native in each windowed mode, but I’m s-s-s-s-sksksks-stuttering if I’m in 1920x1080 and less so if I’m in 1600x1024.

Something to chime in since i just tested a few things.

Some settings seem to be completely borked and they probably dont “exist” which cause many issues.

i7 6700K@4.4Ghz/GTX 970.

1)Vertical Sync = On is working the same way as Half, it drops my FPS from 130-140 while testing stuff at End of Time to 72.

Vertical Sync Half, does the same, something completely broken with vertical sync.

2)Putting everything to Very low, makes my game stutter like crazy on certain areas, putting everything to Medium, stops all sorts of stutter apart from when many things happen on the screen and the fps goes from 70 to sub 20, where its a momentary stutter as expected.

Particularly if i recall the Shadows Setting at Very Low seems to be one of the settings that cause this.

Hell even everything on Ultra gives decent FPS and setting shadows at Very Low makes the stutter start, this at that Lake map in Act 2.

3)There seems to be a mega buggy overlap of settings between Master Settings and Individual settings, and overlapping/forcing of the Master settings system.

4)Each map seems to react completely differently to settings.

Pier/Ship map, Master/Texture/Shadows Ultra, rest a mix of Very Low/Off/Medium, steady 60 FPS, Desert map, less than 5 minutes after, same settings, insane stuttering everywhere between 40-60 FPS.

Lowering everything from Ultra to Medium reduced the stutter by 50% averagely, but it never disappeared in the desert map.

Something is fundamentally wrong with the game settings and their overlapping :stuck_out_tongue:

Just adding a bit of data to the thread : I’m getting abysmal FPS (down to 8 FPS yesterday), with 2 2080 Ti and a Core i9 9980 xe. No overclocking, 64 GB and the game running from a NVME SSD.

Resolution is 3840x1080. Will try lower res when I get the chance to play again.

Completely agree. So many players have ongoing problems with the performance even on the brand new systems for a lot of months. Strange enough, that we haven’t got any feedback from developers about this problem, which is crucially important for arpg. If I can’t run the game smoothly to enjoy the action, why should I play this? Problems with performance make hardcore mode impossible in the game. We don’t even know, whether the devs are working on this or not. I paid my money to support the development, and I have this right - to know what’s wrong and where this performance problem comes from. Do they investigate this? We don’t know. Instead, they are writing a lot about “new log screen”, “new download screen”, “changes in skills” - which is not really important while the game is unplayable for a lot of people due to the very core performance issues.

I don’t know what’s wrong with them. Maybe to use the unity wasn’t the best choice for arpg, or if you made this decision, then, at least, use this engine in a correct way. Moreover, 2 months ago I reported about the wrong values in settings (4098 mb vram). As far as I know, problem is still there. If the devs don’t know, that GPUs with 4098 mb vram do not exist, how they can to create a really optimised and smoothly running game? Nah, I’m angry, yeah.

2080 ti / 8700k, 3440 x 1440. Standing in town I hover at 90 fps, and whether I’ve changed the setting to the very lowest or highest, fps doesn’t change.

Out in the world it gets even lower, pingponging between 80 to 60 to even lower. There’s definitely a problem considering I can get close to my 180fps cap in POE with max settings and during fights.

Well i’ve the same issue since 0.7.2, however in my case it simply could be my old “rig” combined with the Fact it’s still Early Access and WIP, so not optimized. It kinda became unplayable for me - even in the lowest settings because most of the time i rund around with 10-20 fps, which was before not the case (than again the Game 've gotten visually upgraded). So i uninstalled it for now.

I’d really like to play this Game was well, though i’ve still point out that it’s not the full game but still the EA, so obviously a lots of optimization wents at the end of the development cycle into it, otherwise it would take way longer until this project is finished due you need to re-optimize / polish the game everytime something huge is added… and i’d rather have a polished and optimized Fullgame earlier than an unfinished early access which i might be able to play but takes way longer until its finished. EA is still meant for WIP developing stuff which needs to be playtested and the focus does not lie in having the most fun and polished experience.

In my case i even find it possible, that i’m not even being able to play it on Release, so i hope for you guys the performance will be fixed then. (Intel i7 960, 8GB Ram, 770GTX)

I have same issues in my game. I have good PC running lot of games high setting 70-100 fps. But… I buy this game to trying play this game. I start game and fps running 30-40. And then I run task manager GPU shows 100%. I install new drivers and read forums what how other people solve this issues. But there was lots of topics where people have same issues and there is not any tricks. :frowning: Bad thing i realy want play this.

In 0.7.3 I was getting 65-75 fps in most areas with the “bad” areas being around 50fps. I was running with all lighting related settings set to the minimum and all other settings on max. Now, a similar setup gets me only half as many fps. While I had no stuttering before this patch, the game stutters quite a bit in combat, but is smooth otherwise. Fiddling with the settings improved things to a place where I get 50fps in “good” areas and 30fps in “bad” areas. “Bad” areas are usually “woodsy” areas. Indoor is always better. This game used to run poorly on my pc, then it ran well, and now it’s poor again. It’s pretty frustrating.

My rig:
i5-8th gen
8gb ram
1050 4gb
ssd

hi, still have the same problem. i7 9700k rtx 2060 samsung 970 evo pro, 16g ram. 1920x1080 resolution i play in medium but sometimes fps shutter too much. i mean for the pc setup and for medium details is not normal i think