My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Ring of Shields buff not working correctly?

It seems that Phalanx and Sturdy Shields only lasts 1 sec, instead of 4 sec as it stated. I’m not sure if it is only a visual bug on player stats, or is that affect the actual duration of buffs, which is vital. Please look into that. Thanks!

1 Like

Oooo, you’re right, they broke Ring of Shields (at some point after 0.7.6 probably)!

Already made a post and DEV confirmed it and they are aware and fixing it

Sadly it’s still not fixed in 0.7.8f

Still not working.

That would be due to there not being any new patches since 0.7.8f. Hopefully it’ll be fixed in 0.7.9.

Makes sense - I just got the game recently, so wasn’t aware it’s been on the same patch for over a month.

They usually have a ~2 month gap between the major patches & then quite a few small bug fix patches over the next few weeks, then it goes quiet (patch-wise) till the next big one (which should be “soon”).