My Account
× My Account Media Forum Supporter Packs

installation problem


#1

game looks great and might be even better then d3, however i downloaded the client and then tried to install it and it gave me an error saying it could not be installed, went to youtube and tried a couple of their fixes but still not worked. please help, i like to play this game soon.

 

thanks


#2

But there is nothing to install really… Just unpack archive using WinRAR or other similar program (it’s around 3 GB unpacked) and click executable (Epoch_2018_03_24.exe) inside the folder.


#3

gwolf7,

 
Could you please [color=#8080ff]read this thread[/color] and show us your DxDiag?

 
Last Epoch is currently only available for 64-bit versions of Windows. If you’re using a 32-bit Operating System, or using Linux or a Mac, you won’t be able to install the game.