My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

High GPU Usage Causing Lag

Since last night my GPU usage has been 95% plus and it is causing massive lag issues. I have 165 hours into the game and it has been fine up until last night. I tried updating drivers. I am running the NVIDIA GeForce GTX 1050 TI. Any reason my GPU would be running at over 95%?

Did you recently start playing again or have you been playing the current patch for a while? We haven’t updated the game recently. Have you gotten to a part of the game you haven’t been to before?

If there’s a problem with a specific area of the game that would explain it, but otherwise it sounds more like an issue with hardware or other software, unfortunately.

Thank you for the response. I have almost 200 hours into the game, most of which have been in the past 3 weeks or so. It played perfectly fine up until this past week, where the GPU is running at a constant 70%+ and spikes into near 100% at times.

To compare, when running Path of Exile, my GPU usage runs at around 5%. Maybe it is my computer, but it only happens when specifically running Last Epoch, and only since last Sunday. It seems like something in Last Epoch is causing this, though I don’t know what could have changed.

I have tried lowering the graphics settings, removing damage numbers, lowering shadows, but it has no effect at all. Any recommendations to try? Any other information I can provide that may help let me know. Not sure what is causing this. Thanks again for the help.

Maybe I can help pointing that out. Like I’ve mentioned in a seperate thread, Last Epoch’s exclusivefullscreen mode is no real fullscreen in fact. Because you can ALT+TAB out the game, or press the windows-key without minimizing Last Epoch, is evidence of just “windowed fullscreen”. So the exclusive fullscreen simply doesn’t work.

And because of that, your GPU (and MINE as well) have a much higher power consumption, that’s because it always renders the desktop, too in background.
In windowed fullscreen the game is only “layered” over the desktop (again: game won’t minimize by ALTtabbing out).

In fact of this, you can change whatever you want in the graphics settings, you can’t avoid game running in only windowed-fullscreen and versions of that.

TLDR: Last Epoch needs a fix for the exclusive fullscreen mode to work properly / as intended. This would have a huge impact of GPU power consumption and more FPS.

Thanks for the information. That is extremely helpful, even if it is not fixable at the moment. The game is in Beta so I understand there will likely need to be fixes. Hopefully this can be addressed in one of the future updates. If there are any further recommendations that may help alleviate the issue, I am open to suggestions. Thanks again!

Yeah, hope they’ll address this issue as soon as possible, because only when they fix this first, we can give further feedback of what’s causing FPS issues for real furthermore.

I lowered my 4k resolution to 1440p and set shadows to low, for having at least shadows ^^ … and lowered some other settings…

My advice: use the resolution you’re happy with (at least Full HD 1920x1080 or äquivalent) and after that try lower the critical options.

Also if you’re not using FreeSync/G Sync, then at least turn on V Sync, so the frames get limited to optimal 60 (don’t use half V Sync cause it lowers your FPS drastically).

In the advanced graphics settings I set my:
“ambient occlusion” to “very low”, others to “low”, except “terrain quality” to “very high” (because this is just limited by your VRAM of your GPU).

In normal graphics setings I used “TAA” antialiasing and have “low” shadows.

Maybe I could help a bit, until the fullscreen getting fixed (hopefully soon).

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.