My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

FPS Performance & Spell effects

In my experience, the main problem is the blur/distortion effect that they’ve implemented all over the place (see e.g. the poison trail that the Fumes leave behind them for an example). If they just got rid of that even my crappy ultrabook would be able to run most of the game just fine at 30ish fps.

I heard alot of complaining about this so i turned on fps output (f11) and realized I fluctuate from like 150fps to 50fps seemingly for no reason sometimes. I played with the video settings and switching to fxaa antialiasing and low or very low lighting effects seems to help alot but still there’s some strange drops. I"ve never had to drop settings this low just to try to stay over 75fps (the refresh rate of my monitor) If what you’re saying is true that could explain alot, (there’s less server side computation than normal) Generally though most of that is cpu based and fps issues are gpu but different games do vary. I think the art in this game is awesome though and it may be due to that. Even simple spells and effects like lightning aegis are so pretty and turning all the graphics to low doesn’t downgrade them much, whereas other games just look terrible if you turn all the settings to low.

1 Like

PoE is probably one of the most notorious of games that run CPU heavy.

It’s CS:GO except the overall load is less.

My experience with FPS was rather disillusioning too.
The only graphics setting that had a real impact on performance was Shadow Quality. Turning that to the lowest setting brought me +30-40 FPS.

Playing at 3440x1440 I had just above 100 FPS when standing still at the End of Time.
I always have AA disabled as it doesn’t make a difference at anything above 1440p. I also always disable eye cancer options like any kind of blur or DoF things.

Playing as a necromancer quickly showed me that many pets completely ruin FPS. It started with micro stutter. I was able to circumvent the stuttering by removing CPU Cores #0, #1, #3, #5 and #7 from the game process. The same fix helps in Grim Dawn against micro stutter because those games are really CPU intensive and having them running on Core 0 means they share with Windows. And that causes the stutter. The other cores are generally recommended to be disabled (or to remove Hyperthreading alltogether for gaming).

That improved my FPS too but only by a bit. Still in busy locations especially with many pets it gets so slow that it’s not fun to play anymore.

The system is three years old but cost me 12k and it has no problems with other games. No heat problems for example.

Edit:
Had time to try other classes and builds now. The big FPS drainers are only happening as Necromancer and only if I use skills that summon very high numbers of minions, like “Summon Wraith” or “Wandering Spirits”. If I don’t use those, my FPS take some hits when many enemies are on screen but it never really goes below 30 anymore. At my resolution and with all those maxed settings (apart from Shadows, which I still have to set to the lowest value) that’s ok. It could be better but I have no issue anymore. :slight_smile:

just had a map full of wengari shamans and my fps on medium settings went all the way down to 6-8 frames. playing on laptop with i7 and rtx2060. Absolutely frustrating experience, to a point where I, a person who rarely posts on forums, found current topic and wrote a reply hoping this will give devs some extra incentive to look into the issue. Overall game feels amazing, if not for the occasions describe above and crashes at the start of a monolith run (lets hope 0.8 will fix it), but those 2 are enough to stop even trying to play in HC, cause the risk of dying is too high at the moment.

1 Like

I noticed the new patch (0.8) mentioned very few performance improvements.

What it did mention was some Shadow improvements that saw a 6 FPS gain across the board, so that will be interesting to see if it does much.

Optimized shadows. This achieved a 6 FPS average gain across the game.
    There are now shadows present on the Very Low setting as they have minimal performance impact now.
Added a “Detail Shadows” option, which can be unticked for further performance improvements if desired.