My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Drivers not recognized?

I just installed the game, and it seems the game does not recognize my graphics driver/hardware. I’m using Nvidia Geforce GTX 860M. Has anyone come across this issue? How did you resolve it?

Could you please post use the Upload button to attach your system information as an attachment to a forum post? We’ve a support article for this which may be helpful;

https://support.lastepochgame.com/article/79-collecting-system-information
 
Moving thread to Technical Support.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.