My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Crash Game (pixel screen, burned out power supply)

Hello. Sorry for my English. I really like the game, I do not regret the money spent on it. However, I ran into a very unpleasant problem:

Half a year ago, during the game, my entire screen turned into a rainbow of pixels. I could do nothing but force shut down the computer. At that time, everything worked out and after re-inclusion, he worked on. Then in fright, I decided to quit the game for a while.

But now, after half a year, I returned to the game, in the hope that they fixed that bug. But the situation repeated itself. I fought with the boss and at some point the screen again became a rainbow of pixels. And again only forced shutdown helped. But this time, my 550w power supply burned out. He is not even a year old. The motherboard also partially suffered. I had to buy a new unit and pay for repairs.

I do not make claims to the game, I just want to stop being afraid and play it further. I hope you can help me somehow.

Here are my accessories:
Windows 10.
Gigabyte AMD B450 SAM4 MATX B450 Aorus M
Samsung 8Gb PC21300 DDR4 M378A1G43TB1-CTDD0
WD SSD Original SATA III 240GB S240G2G0B Green M.2 2280 (for system)
HDD 1TB, Western Digital Blue, WD10EZRZ (the game is on this disc)
AMD Ryzen 5 2600 AM4 BOX YD2600BBAFBOX
Gygabyte PCIE16 RX VEGA 56 8GB HBM2 GV-RXVEGA56CAM OC-8GD
Thermaltake ATX 550W LT-550P (now 650W).

If you need, can send dxdiag.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.