My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Wrong tooltip or wrong requirements for frenzy

Something about the requirements for frenzy under Sabertooth is wrong. Either you only need one point, but it says I need 2 points. Or the dots are wrong, and not telling me I actually need 2 points.

frenzy_points

2 Likes

It’s supposed to require two points, and the display has been fixed internally. Thanks for the report!

1 Like

still displaying 1 point needed

1 Like

Just noticed this was still displaying wrong myself.

Screenshot from Beta 0.7

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.