My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Unable to launch the game through Launcher

Hello,

I turned my pc on and started the game through launcher like I usually do, and I got an updated which I downloaded and after “installing” part I get an error. (print screens attached)

I can launch the game directly without the laucher (through the app folder), but I’m afraid I won’t be able to download any patches if I’m unable to do it through launcher.

Can anyone help me with this? Thanks
https://imgur.com/0uN4hY8
https://imgur.com/sN56gXN

Hi there,

Sorry to hear about this!

If you haven’t already done so, could you please try performing a Clean Boot, then right-clicking on the Launcher and selecting Run as Administrator? This will help prevent any third-party software from interfering with the Launcher, which greatly helps us narrow things down.

1 Like

Hey, your suggestion worked. I have restarted the pc before and also tried running it with administrator saparately but it didn’t work. Now I followed ur advice and it fixed the problem. Thank you!

Thanks for the update!

I’m very glad to hear we managed to resolve the issue. :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.