My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Tornado Skill wrong level requirement display?

Hi guys,
i’m just leveling a Primalist and i realised that the Tornado Skill at Shaman mastery is displaying a level 10 requirement. I think it should be level 5 since you can see the symbol underneath Earthquake?

Thank you for your response!

This will be fixed in 0.7.7e. It unlocks at level 5, not 10. Thanks!

1 Like

Thank you :smiley:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.