My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Titan's Canyon Teleport to Maj'elka Waystation missing

I am stuck at Titan’s Canyone and cannot progress to Maj’elka Waystation it seems that the portal to Maj’elka Waystation is missing.

There should be a doorway just to the right of the boss arena, could you post a screenshot of what you see to an image hosting sight? Or if the door isn’t working, uploading a video clip somewhere would be ideal.

Here is a Screenshot: https://prnt.sc/pfcb9t

In addition my minimap is completely dark. As far as i checked at the place my hero is standing in the screenshot there should be the teleport to Maj’elka Waystation.

Oh, you’re supposed to be able to walk past there. Sorry about this-- I’ll make sure this gets fixed as soon as possible.

Thanks for the fast reply :slight_smile: .

Any idea when this might be patched?:slight_smile:

ye i’m stuck at the exact same spot indeed :slight_smile:

@Mallar @Sirris @Thyworm Fix for Titan’s Canyon is out now, sorry about that!

1 Like

@Hackaloken I still cant walk past that point - sure its fixed? :sweat_smile:

Just checked again on steam-- worked for me. Which OS and platform (standalone/steam) are you on?

I have played more than 8 hours straight - tried rebooting the game and it worked :sweat_smile::sweat_smile:

Ah well the update was released 7 hours ago :wink:

I had been playing from about 11am EST to 7pm EST today and encountered this issue. Upon finding it I looked it up and found this thread. I restarted the game, let it patch, and had no issues crossing past the place i was previously blocked at.

Thanks for the quick response to the issue!!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.