My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Teleport not functioning?

Hi, glad to see you guys have moved into the Beta stage, and I am enjoying my first forays into the new world.

One little problem though, I have a full inventory but can’t teleport back to town? I have tried pressing T and clicking on the task bar icon but nothing happens.

As I recall, you used to be able to flit back home whenever you wanted/needed to, am I doing something wrong, or has this now been changed?

Thanks for the replies

If this is early on in the game, it may not be active yet. I don’t think you get portals until you reach the Council Chamber. I was likewise confused at the beginning…

@Deathbane Have you initially made it to town / found your first vendor? Like @gwmngilfen said, I don’t think the TP works until you get to town.

I’ve found also found some weird object interaction issues, try casting another skill or interacting with the screen and then TPing.

If that doesn’t work, grab your game log and make a bug report :slight_smile:

Hi, ok as far as I am aware, I have been to the first ‘encampment’ and have chatted with the NPCs, moved on to the next quest, and now find myself before the ‘Find Leena and the shard’ Q.

To clarify, I have found the Travellers camp. I can run back to it, sell stuff that way, I guess you have to find the city, killing the extra mobs etc does help with XP gain, it would have been better if the Portal was blanked out until it becomes available.

I will continue my journey see what happens.

aha… reached the ‘Last Refuge’ it all becomes clearer now…

They should blank out the TP Icon until you can use it really, to avoid confusion.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.