My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Stuck on "Finding Pannion" - what should I do now?

Hey there,
the last thing I did on “Finding Pannion” was to kill the void corrupted students.
Now I should return to Elder Gaspar (which I did) but I cant talk to him. Well ok, I CAN talk to him but he doesnt want to help me at all :smiley:
What did I do wrong? How can I complete the quest now?

1 Like

Try restarting?

This bug happens with old characters who have done old pannion quest before 0.7.10.

These old characters get “Finding Pannion” quest when they zone to Last Archive, but can’t finish the quest.

(This thread should probably be moved to bug reports)

1 Like

a friend got the same problem not sure what to do as he tried restarting teh game. he just created a new char

1 Like

got same problem. . … . so annoying

I have the same problem,

Have you tried getting steam to verify the files? That can fix the weirdest stuff.

I’m having the exact same problem. Does this mean I cannot complete the game with this character? I really don’t want to restart, I barely have enough time to play as it is.

(Note, I tried restarting the game, verifying local files, going to other places on the map and resetting the town, etc, nothing works)