My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Steam Update?

The game will not update to the latest patch on Steam. The update process keeps pausing and no matter how many times I click on resume it goes right back to pausing again.

Do you have another game from steam running at the same time (Steam doesn’t like that)? Do you have enough space on the drive to update? Does it pause or does it just say “allocating space”? What does it say when it pauses?

Thx for the reply, None of the above. No games running, lots of space. It flat out pauses with no explanation whatsoever. Goes from unpacking to pausing.

OK just did a complete reinstall and that seemed to have worked.

Thanks for sharing what worked for you, Evok. I’ve marked that as a solution. :smile:

Another potential fix for this would be to try Repairing Last Epoch Through Steam. If anyone finds this thread through searching for symptoms they also have, I’d recommend trying that.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.