My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Skill Tree UI Inconsistency

These two routes display lines on the skill tree differently, they should be identical:

  1. When you gain a new skill level an icon appears next to your mana. Click it.

  2. Open the Skills window and click the skill that just levelled up.

Is there supposed to be an image there?

Wasn’t possible - can’t get the icon next to the mana back once I clicked it. It’s reproducible by levelling up any skill. I’m at the end of my playthrough so can’t easily do it.

Oh, you mean the lines that connect the nodes on the skill tree. When I clicked on the lvl up icon next to the mana the lines connecting nodes that I hadn’t put any points in were only bright up to the half-way point where the dots are, but if you just use the S key to get to them then the lines connecting the nodes are bright all the way to the other node!

Unfortunately, it doesn’t seem to happen all the time. I had it happen on one character but not on my Spellblade…

1 Like


The first screenshot is when I clicked on the skill lvl up icon to get to Enchant Weapon, the second screenshot is when I closed out of that screen then went back in via the S key.

I’ve taken a look at this and I think the problem is that the second half (on the other side of the dots) does not get lit up immediately after putting points into a node regardless of how you opened the skill tree.

When you close and reopen the skill tree after unlocking a new node, the second half is lit up correctly.

I’ve made a note of this internally.

1 Like