My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Skill tree not unlocking

Trying to put points past the 25 mark in my Paladin tree does nothing, the counter has just locked at 25 and respeccing does nothing to it either so I can’t do anything above the 25 points to unlock line. I now have 68 points put in here and the counter still says 25.

Could you please post a screenshot?

https://imgur.com/CenoCci here you go, went to play on my mage instead and encountered the same thing. They’re all characters from ages ago and all talents was reset when i logged on today, not sure if that matters.

1 Like

So, the way mastery classes work in Last Epoch is that you have access to the bottom half of all three, and can unlock access to the entirety of a single mastery class by completing a quest available in the End of Time town hub. (This choice is permanent.)

As you don’t appear to have chosen the Paladin (or any other) mastery class, the game not allowing you to spend points in passives located higher up in the Paladin mastery class.

I’ve just looked at this in-game, and the game isn’t currently communicating this very well. I’ll speak with the team about ways of clarifying this, however I don’t think we’d be able to make and test any changes in time for the changes to be included in our next update.`

 
Edit: The numbers for each class are intended to track how many points have been spent in that class, however they appear to instead be showing how high up that class you have unlocked access to. I’ll add this to our issue tracker so it can be fixed in a future patch.

Aha! So it’s probably because the characters in question is older than the quest to pick a class. I have not played on these characters since patch 0.7.0e or something like that. And i did play a paladin at that point, I even have the skill Judgement at level 20 in my spellbook, can’t select it now due to not having the class unlocked tho. Will I have to make new characters or can I go pick this quest up somewhere?

I think you should be able to perform it on old characters, though I haven’t personally tried doing so.

Here’s how you would check;

  • Go to the End of Time town hub.
  • Go up the ramp (there is a stairs icon on the mini map).
  • Have your character turn left, and speak with the Forgotten Knight.
  • If she doesn’t offer the The Power of Mastery quest, talk to Elder Gaspar.
  • Complete any available conversations with Elder Gaspar, talk to Forgotten Knight again.

Right, thanks! That fixed it, I can now put points in the area that was greyed out before. Looks like my trees was locked to the old system where you just clicked in the talent window when you had 25 points there or something.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.