My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Rebuke problem

“for 5 seconds after channeling” part of these nodes I’ve picked aren’t giving any increase to my armour, elemental protection or movement speed after the channeling is complete. It only gives the buff during the channel, thou only the armour, health regen and 250 elemental protection. The 15% movement speed buff does not apply. At least it does not show under character sheet movement speed tooltip. During the channel and after it’s complete, the movement speed stays the same.
Also, think the math behind the armour increase might be a tiny vee bit wrong? Would help if someone else also tested this, but at the moment from my current 431 armour with two points in armour polish (which is 40%), increases to 12151. 431 + 40% = 12151, hmm.

We’ve made changes to Rebuke, can you check if this problem still persists? Thanks.

Current setup. https://imgur.com/a/hvkpCm2

Movement speed gets increased after the channel is complete, the amount is right +15%, thou it persists way more than 2 seconds or 4 seconds with 5/5 Solemn VoW. Don’t know how to test for how long or what the trigger is for resetting it back but the 2 second after channel is complete isn’t working properly.

The armour part.

Unbuffed, while standing in a neutral zone, sitting on 60&, 985 armour atm. With 3 points in Augmented plating which is 90% more, my armour increases to 63%, 1115. If my math is correct (not sure if it is) the amount increased, compared to the previous one, is fixed? Anyways, would suggest you do the math as it’s not one of my stronger suits. Xd

The new node, Protective Legacy. The “persists for 2 seconds after you finish channeling” and with 5/5 in Solemn VoW, which would/should be “4 seconds after you finish channeling” isn’t working.
The buff is there while holding my right mouse button. Quick button for casting rebuke, but after the channeling is complete the armour and elemental protection return to their initial state, without the 2 or 4 seconds of increase given with the node “Protective Legacy”. Even after quickly pressing the skill to channel for less than a second, the +2 or +4 seconds increase of armour and elemental protection after channeling does not apply.

1 Like

Thanks for the detailed report! This should all be fixed next patch.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.