My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Need help please, game runs slow on good pc

So I found this game very interesting, looks very fun and I would love to play it. For some reason, the game runs slow. I have a friend with the exact same pc as me and he has all his graphic settings on high and the game is smooth and flawless for him but for me I click and then a second later my character moves. I have tried even putting the graphic settings on very low and it still has this issue. I have re installed the game 3 times through the steam launcher and the Epoch launcher and nothing seems to work. I feel like I’ve wasted my money. If anyone has any insight on the problem i would truly appreciate it because i would love to play this game.

Well when it comes to troubleshooting there several ways to go.

First I would like to ask you to provide the following information -

Run - dxdiag click on See all information and upload the file. Without knowing the system it’s just shooting in the dark.

From your end you can -

Check your system resources - before running the game open Task manager and see how much of the resources are free, if there are apps that are utilizing a huge portion of your Memory or CPU, might be there is something eating up your resources.

Check if your drivers are up to date, including Windows updates (yes sometimes Windows updates can fuck you over, but what that happens the whole internet explodes and then you wait for a week or two)

If you are using a Laptop, check which Graphic Adapter is being utilized by the game.

Hardware stuff to check -

Check your System’s temperature if you have components overheating, well time for a new cooler.

Check the health of your storage - defragmentation is a good first step, you can also run the following -

chkdsk x: /f /r (X represents the targeted drive)

Hope this helps

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.