× Media Forum Supporter Packs

Last Epoch Forums

Necromancer Download


#1

I’m having difficulty downloading the Necromancer PreAlpha. I left it to download overnight, but it stopped at some point and would not resume. I guess the download link has an expiring token?

I’ve started it again today, but it is only downloading at 50kb/s maximum, so it will take hours. Maybe it takes too long and the token expires? My line speed is much more than the speed it is downloading at. I’m downloading it through Chrome in Windows 10.

Suggestions?

Edit: The second attempt has also stopped now, with Chrome reporting “Network error” :frowning:


#2

I’m very sorry about this! Could you please check the e-mail associated with your Last Epoch account? I’ve sent you a mirror, so hopefully you’ll have better luck downloading the Necromancer-enabled version of Patch 0.4.11 from there.


#3

Thanks, I’ve just seen the email now :slight_smile: The new download is running much faster than the other one, so hopefully it completes.


#4

Thank you the quick response!


#5

Thanks – I have the file.


#6

Thanks for the update!