My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

My whole character just completely broke

I don’t even know where to start. I was trying to craft a new weapon, it fractured, I tried to shatter it:

After that, the Rune of Shattering visually got stuck on my cursor so I logged out to reset it. When I tried logging in I was met with a Frankenstein’s Monster type of screen, a mashup of the character select screen and ingame inventory + a couple other things. Sadly I forgot to screenshot this.

As I got into game, I got the usual inventory bug, where you have it open by default and can’t close it, which also laggs me out like crazy by the way. At this point I brute forced it to close the inventory (spamming the X and ‘I’ and such). Cool, it worked.

Cut to me trying to clear a Monolith I just opened, but wait, I’m dealing no damage, and I don’t see my weapon on either (visually, it was on me in my inventory). Tried reequpping a couple times and went on with my life, struggling to clear stuff. Also I forgot to mention I was met with an empty skill bar when I relogged, with just the starting Blood Rip skill on my Q.

That’s me now. All my stats are 0 with my gear, negative without them. I’m sad. 2nd time my Harvest Reaper build goes down to bugs :frowning:

Relog didnt fix the problem, but restarting the game did. This is getting weirder by the minute

At least you weren’t beta-testing a self-driving car

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.