My Account
× My Account Media Forum Supporter Packs

Monolith - Quest not completed after killing boss, and no more objective marker


#1

I am playing on the patched released earlier, 0.7.0e, and running a Monolith instance (second one since patching). I had the objective to kill the Frost Wyrm, and cleared the zone before finding it. After killing the boss, my Quest changed to “Go to area and complete objective”, and there is no objective/quest marker on my map at all. I ran through the entire instance to make sure nothing respawned and I didn’t have a portal somewhere. So now I’m sitting in the instance about to manually TP out since I have no other option.

One thing to note is that I had my Quest log minimized at the time of the boss kill. The attached screenshot is after I restored it.


#2

Update:

I manually Tp’d back to Echo of a World and completed my Mono run successfully, even though my objective wasn’t flagged as “Complete” in my log. I began running a new one and my Quest Log still said “Go to area and complete objective”. Once I killed the three turret/towers, my Quest Log went back to normal, providing me the actual objective and marking it “Complete”. I was also given the “Open Portal” dialogue, which worked as normal.

I left my Quest Log open this time for the second run, so it might have to do with minimizing it.
Quest Log at start of second Mono run:


#3

New User - could only upload one image. Here is my Quest Log after completing the objective in that second Mono run:


#4

Yea can say this has happened to me twice today, first time had no clue what happened but was able to recreate bug by minimizing the quest log on the right and completing the monolith. when the monolith quest was the cleanse one i did not receive any drops from the completion as well but was able to TP back to echo and get my chest.