My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Mac Build Shader Support broken

The Mac build looks like it is entirely broken at them moment. When I try to start, it goes to a black screen and I am then required to force quit. There

Here are the contents of the log file

Last Epoch.app/Contents/MacOS
➜ md5sum Last\ Epoch
a5f375ec1927f0e459868edcfeccb9c7 Last Epoch

Library/Logs/Unity took 1m 49s
➜ cat Player.log
Initialize engine version: 2018.3.8f1 (fc0fe30d6d91)
GfxDevice: creating device client; threaded=1
Renderer: AMD Radeon Pro 580X OpenGL Engine
Vendor: ATI Technologies Inc.
Version: 4.1 ATI-2.8.38
GLES: 0
GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable G
L_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
OPENGL LOG: Creating OpenGL 4.1 graphics device ; Context level <OpenGL 4.1> ; Context handle 444926976
Begin MonoManager ReloadAssembly

  • Completed reload, in 0.159 seconds
    Shader ‘MysticArsenal/MysticHSV’: fallback shader ‘Particles/Additive’ not found
    The referenced script on this Behaviour (Game Object ‘Graphics warmup’) is missing!

(Filename: Line: 294)
WARNING: Shader Unsupported: ‘Hidden/PostProcessing/Debug/Waveform’ - Pass ‘’ has no vertex shader
ERROR: Shader Shader is not supported on this GPU (none of subshaders/fallbacks are suitable)WARNING: Shader Unsupported: ‘Hidden/PostProcessing/Debug/Waveform’ - Setting to default shader.
WARNING: Shader Unsupported: ‘Hidden/PostProcessing/MultiScaleVO’ - Pass ‘’ has no vertex shader
ERROR: Shader Shader is not supported on this GPU (none of subshaders/fallbacks are suitable)WARNING: Shader Unsupported: ‘Hidden/PostProcessing/MultiScaleVO’ - Setting to default shader.
WARNING: Shader Unsupported: ‘Hidden/PostProcessing/Debug/LightMeter’ - Pass ‘’ has no vertex shader
ERROR: Shader Shader is not supported on this GPU (none of subshaders/fallbacks are suitable)WARNING: Shader Unsupported: ‘Hidden/PostProcessing/Debug/LightMeter’ - Setting to default shader.
WARNING: Shader Unsupported: ‘Hidden/PostProcessing/FinalPass’ - Pass ‘’ has no vertex shader
WARNING: Shader Unsupported: ‘Hidden/PostProcessing/FinalPass’ - Pass ‘’ has no vertex shader
WARNING: Shader Unsupported: ‘Hidden/PostProcessing/FinalPass’ - Pass ‘’ has no vertex shader
WARNING: Shader Unsupported: ‘Hidden/PostProcessing/Uber’ - Pass ‘’ has no vertex shader
WARNING: Shader Unsupported: ‘Hidden/PostProcessing/Uber’ - Pass ‘’ has no vertex shader
WARNING: Shader Unsupported: ‘Hidden/PostProcessing/ScreenSpaceReflections’ - Pass ‘’ has no vertex shader
ERROR: Shader Shader is not supported on this GPU (none of subshaders/fallbacks are suitable)WARNING: Shader Unsupported: ‘Hidden/PostProcessing/ScreenSpaceReflections’ - Setting to default shader.
WARNING: Shader Unsupported: ‘Hidden/PostProcessing/DepthOfField’ - Pass ‘CoC Temporal Filter’ has no vertex shader
WARNING: Shader Unsupported: ‘Hidden/PostProcessing/Debug/Histogram’ - Pass ‘’ has no vertex shader
ERROR: Shader Shader is not supported on this GPU (none of subshaders/fallbacks are suitable)WARNING: Shader Unsupported: ‘Hidden/PostProcessing/Debug/Histogram’ - Setting to default shader.
WARNING: Shader Unsupported: ‘Hidden/PostProcessing/Debug/Vectorscope’ - Pass ‘’ has no vertex shader
ERROR: Shader Shader is not supported on this GPU (none of subshaders/fallbacks are suitable)WARNING: Shader Unsupported: ‘Hidden/PostProcessing/Debug/Vectorscope’ - Setting to default shader.
UnloadTime: 0.844235 ms
Fallback handler could not load library /Users/callum/Library/Application Support/Steam/steamapps/common/Last Epoch/Last Epoch.app/Contents/Frameworks/MonoEmbedRuntime/osx/data-0x7fa11e9eb600.dylib
Fallback handler could not load library /Users/callum/Library/Application Support/Steam/steamapps/common/Last Epoch/Last Epoch.app/Contents/Frameworks/MonoEmbedRuntime/osx/data-0x7fa11ea79e00.dylib
Fallback handler could not load library /Users/callum/Library/Application Support/Steam/steamapps/common/Last Epoch/Last Epoch.app/Contents/Frameworks/MonoEmbedRuntime/osx/data-0x12178c000.dylib
Facepunch.Steamworks Unity: OSXPlayer
Facepunch.Steamworks Os: Osx
Facepunch.Steamworks Arch: x64
/Users/buildbot/buildslave/steam_rel_client_osx/build/src/common/pipes.cpp (770) : Assertion Failed: fatal stalled cross-thread pipe
/Users/buildbot/buildslave/steam_rel_client_osx/build/src/common/pipes.cpp (770) : Assertion Failed: fatal stalled cross-thread pipe
/Users/buildbot/buildslave/steam_rel_client_osx/build/src/common/pipes.cpp (770) : Fatal assert failed: /Users/buildbot/buildslave/steam_rel_client_osx/build/src/common/pipes.cpp, line 770. Application exiting.

thank you Moncky we believe we know the issue. now to get a fix :wink: wish us luck.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.