× Media Forum Supporter Packs

Last Epoch Forums

Launcher stuck at 90.1%


#1

I have attempted every fix that has been suggested on the forums here and I am having absolutely no luck, The launcher just gets to 90.1% and never proceeds. Any help would be appreciated.

OS: Windows 7

Windows Defender: Exception Added

Anti-Virus: Off & Exceptioned

Running as Admin: Yes

Troubleshooting: Re-installing, restarting and even cleaning out registry.

Launcher-log: pastebin.com/9DMnh2YJ


#2

Very sorry for the inconvenience, but could you try re-installing again?


#3

I’ve reinstalled the launcher about 6 times now. I’m not sure that is going to fix anything, but yes I will try again.

EDIT: Re-installing has fixed nothing unfortunately. The same problem still persists.


#4

I also have the same problem and I tried 3 times already!


#5

Hey guys, very sorry about this. We are working on fixing this. I actually pushed out a new version of the launcher yesterday in hopes that it would fix this problem. Could you email your launcher logs to [email protected] or send them to me in the discord? They really help us figure out this issue.

Thanks


#6

I completely disabled windows defender firewalls, all of them and it worked. I was having same issue until then. Maybe give it a try?


#7

Thanks for the post, pmpadgett! Glad to hear you managed to resolved it.

Please don’t hesitate to reach out to us if you ever need a hand. :slight_smile:


#8

Having this issue. Have disabled firewall and everything; even added extra exceptions. No luck


#9

Sorry to hear that!

Please send an e-mail to [email protected].


#10

I have tried everything and still not making any progress. Is their perhaps some kind of mirror link or something with a fully patched download available or something? Been dying to try all the new changes in alpha.


#11

This please.

I’d rather just download the fully patched version to play. I honestly feel let down for paying $50 and I can’t imagine some that paid $1000…


#12

As per my previous post, please e-mail [email protected] if you’re affected by this.

Thanks!