My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Launcher Application Error 0xc0000005

Launcher crashes with 0xc0000005 immediately upon launch. No logs from it that I can see.
It worked the first time I installed the game (don’t remember the version). Currently the game is stuck on 0.7.7d. (I can still play online by launching app\Last Epoch.exe directly.

Specs:
Win10 Pro
AMD Ryzen 7 3700X
Gigabyte X570 AORUS ELITE
RTX 2070 Super, driver version 445.75
32GB RAM

I don’t have any additional AV or similar software besides default Windows protection.

On a side note, sometimes when running the launcher installer, it shows error Out of system resources (but continues running). It seems inconsistent, though.

Naturally, right after making this thread, I had an idea that allowed me to update the game to the latest version. The launcher is still broken, though.

TLDR: run LastEpochLauncher.exe with command arguments found in launcher-log.txt from last successful launcher run.

Some of the things I did during troubleshooting were various combinations of reinstalling, trying to run patcher/LastEpochLauncher.exe by itself and deleting stuff. Some of those deleted things were log files. I noticed that when running the patcher, it expected some command line arguments:
2020-06-10 11:14:35.355 -04:00 [ DEBUG ] <InputArgumentsPatcherDataReader::Read> Expected the secret and installdir to be present in the command line arguments.
I remembered that I saw those somewhere. After rummaging through through my Recycle Bin I dug out launcher-log.txt which contained the key line:
[DEBUG] Wed Apr 1 21:35:05 2020 - Preparing execute target: "D:/Games/Last Epoch/patcher/LastEpochLauncher.exe" with arguments: ("--installdir", "D:/Games/Last Epoch/app", "--lockfile", "D:/Games/Last Epoch/.lock", "--secret", "SUPERSECRETMAYBE", "--online")

So, that’s exactly what I did:
D:\Games\Last Epoch\patcher> .\LastEpochLauncher.exe --installdir "D:/Games/Last Epoch/app" --lockfile "D:/Games/Last Epoch/.lock" --secret "USEYOUROWN" --online

This got my game updated to the latest version. The launcher itself still remains broken.
I’m not sharing my secret key here because, well, it says “secret.” Hopefully this information will help those in a similar situation.

As a bonus, it seems that the last successful Launcher run I had was on April 1st. I don’t play Last Epoch every day, so I’m not sure how useful this information is.

Thanks for the info. We’ve had some issues with it not figuring out space availability correctly during an update. We are working on a complete overhaul of the whole launcher that will fix these issues. 0.7.7d is gigantic compared to 0.7.8 as far as space on disk goes. It may have been attempting to allocate space for both versions simultaneously. If this happens again before the launcher upgrade, you might need to temporarily free up some space on the drive and then move the stuff back.

In your troubleshooting, did you attempt to download a fresh launcher from our website? You can change the name of the directory of the old one and then install the new one and then before it actually starts downloading, move the game folder into it and trick it in to thinking you’ve got the game downloaded already and it should just pick up as though nothing happened. I know those instructions are a little vague but I get the impression that you know what you’re doing enough that it will make sense. Let me know if you need more details.

Thanks for the reply and suggestions, Mike. I understand what you mean by moving the folders.

My D drive, where the game is installed has 1.5TB free. My system drive C has just under 400GB, so maybe it’s looking at that one first when checking for system resources.

I tried downloading the newest launcher installer from the website and:

  • installing over top of current installation
  • uninstalling completely and reinstalling (without reboots in between)

The launcher simply immediately crashes without attempting to download anything, even on a fresh install.

With being able to bypass the launcher for updates and playing the game, I think I am OK for now, but let me know if you want me to try anything else. Otherwise, I’ll just wait for the new launcher.

I’m not sure if the new launcher will be available before our next content patch. One option would be Steam Account Linking to have Steam install and update the game as a workaround.