My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

I can't log in

i got this problem! Screenshot (30).zip (2,1 MB) say: 0.7.3 username are no longer accepted for log in ç.ç can someone explain me this??? ò.ò

Hi!

The error message shown in red (Failed to log in. if this problem persists please contact support) is the main problem here, and can be caused by a few things.

We changed login from using Usernames to using email addresses in patch 0.7.3, so we added that message in case people were unaware. Please make sure you’re using the email address for your account, rather than username.

Are you on Steam or the Standalone client? Have you been able to login successfully in the past? Your log file and system information would be helpful as well if the issue persists.

1 Like

thank you yes, I solved it I waited a while and I managed to log in, in any case, I have the game on steam, and I always log in with my email, but no problem I solved thanks

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.