My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

I can't get past character creation

Hi there,

New to the game, fresh install and when I try to enter the game a skillbar appears and I get stuck. I’ve tried deleting the character, remaking the character, all of the fixes for similar issues posted on here and a fresh install. After an evening of attempts i’ve got nowhere and I simply can’t play.

I have attached two screenshot examples and my game logs and graphics ini. Please can you help me.

logs.zip (968.2 KB)

Sorry about this! Thanks for uploading your log files and including screenshots.

During this process, have you tried deleting the Saves folder directly? It’s located in the same place as the log files you uploaded. I would recommend closing the game, deleting the entire folder, and then starting the game again.

It appears that you’re experiencing a bug that we fixed internally after the last patch, so this shouldn’t be a problem for anyone else after 0.8 is released.

Please let us know if this advice works or if you need further assistance.