My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Huge fps spikes, mostly when casting spells

Hello,

I really like the game so far, but its sadly not fluid at all.
When I turn down all the graphic stuff I get around 100-120 fps. But sometimes when I cast a spell, (especially glacier, (ice) nova or teleport with novas) the game goes down to 1-5 fps.
I also sometimes have less hard drops (to ~30) without any spell casted.

The strange thing is, this does not always happen. most of the cases the fps barely changes when casting a spell.

I am using the steam client, is there any possibility to try the raw windows client when I bought the game from steam?

graphic card: Nvidia GeForce GTX 1060 6 GB
cpu: AMD Ryzen 5 2600 Six-Core, 3400 MHz
ram: 16gb (not sure about the manufacturer, but probably does not matter)

This does not happen in other games, so I guess its not my hardware.

Best Regards

Sorry about the issue! We’re working on optimization with each patch, so hopefully this will be improved by our next patch. We’re aware of skills dropping FPS in some cases, but it’s rare that they cause that large of an FPS drop. If you post your log file after it happens again we can make sure there isn’t some other bug happening.

The actual game is exactly the same between Steam and the Standalone, how the game files are distributed to you is the only difference.

output_log.txt (2.6 MB)

The “hard drop” happened at least twice in this play session, which was probably roughly an hour.
Is a shorter session and therefore a more narrowed down file more useful for you?

I’ve actually seen the reverse occur for me. Just doing melee attacks seems to trigger lag spikes sometimes depending on the number of nearby enemies.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.