My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Game stuck "not responding" when trying to run it

I purchased the game through Steam yesterday and every time I have tried to run it immediately goes to not responding and doesn’t even make it to the launcher. Is there something I can do on my end to rectify this or is an issue that is already known and is being worked on to fix it?

Hi there,

Could you please post both your system information and, if one exists, the game’s log file?

DxDiag.txt (100.3 KB)

I don’t have a games log file. My guess would be because it never actually launched it didn’t create one.

My apologies for the slow response here!

Unfortunately, it seems that your PC does not meet our system requirements, specifically your GPU.

Because a log file is not generated, that means the game fails during the inital load process. Your GPU has 1.5GB of VRAM when our minimum requirement is 2GB. So, I would recommend upgrading to a newer graphics card, ideally with 4GB of VRAM or higher. An RX 580 of GTX 1660 should suit you well, in terms of new graphics cards.

If Last Epoch is installed on a Hard Drive, you could also try an SSD, but the GPU is more likely to be the problem.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.