My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Game Crashing

My game crashes constantly. Whether I am playing my pally or playing my mage doesnt matter. I have a solid rig, it was built in 2020. So I know its not my rig. My game drops and pops up a bug report that appears to be sending a msg to last epoch devs to see whats going on. I am hoping that everytime my game drops that it is actually sending over helpful info and that I am not the only one dealing with this. Please help if there is something I can do to be able to play this game without FREQUENT game crashes. I just hit wave 50 in arena and my game crashed…pretty frustrating.

Are you using lightning blast? Are you doing anything specific when the game karks it?

Ive used Elemental nova and it crashes. Ive used firebolt and it crashes. warpath, glacier, etc. Doesnt matter. It crashes all the time no matter what character and what abilities I use.

I brought a new rig this year to, a top high end gaming rig. As I have always brought mid ranges in the past!

The first 3-4 months the PC did have a lot of teething troubles. With games crashing, even getting BSoD etc!

But after several Windows and driver updates the system is now stable.

As such my advise is to make sure Windows is fully updated. Check all your drivers regular. If your using GeForce card, make sure you have the latest driver on GeForce experience! You know all the normal stuff!

I would also open up the CMD window in Admin mode and type [sfc/scannow] this will check your drive for any errors. My brand new rig had several errors, the first time I ran this!

Just made sure all drivers are updated and windows is current. Trying to run command but its saying I must be an admin running a console session in order to use the sfc utility. So I am working on getting that figured out. Ill let you know if I get this to work.

ok, I got it figured out and its running the scan now.

ok, updated all drivers, ran the CMD check, updated windows. Game just crashed. Whats next?

Game is still consistently crashing. Pulls up the last epoch logo and shows it loading like its sending an error report. Please Help me figure out how I can play this game without dropping every 5 minutes. Its no longer enjoyable.

What video card do you have?

Radeon rx5700 xt

I think almost all of us with this problem are using that card.

really? thats insane. Do the devs know about this issue?

They do. There’s a thing that works for some people in another one of the threads. It doesn’t work for me but it’s worth a shot! It’s a really simple and quick thing to do too.

Do you know where I can find that? Im willing to try anything.

Would that be this post? There’s other instructions on posts #67 & 72 of that thread.

I also have a Radeon 5700XT and can’t play Last Epoch because of constantly crashing every few minutes.
I updated all drivers and even tried beta graphic driver but nothing helped.
Also tried any kind of graphic settings…

What can I do to fix this?
I tried out LastEpoch some month ago and didn’t have this issue.

Have you tried this?

Yes, but I dont get it…

Blockquote
EDIT2: Don’t use the installer. Instead just download and unzip the folder. Then copy 2 files and paste them in the game’s folder where the game executable is. The first file you always have to copy is the “dxgi.dll” file. The second one depends on which DX version the game you want to apply this to is running. In this case Last Epoch is on DX 11 so you also have to copy the “d3d11.dll” file.

I downloaded, extracted the files. So I have this dxvk-master folder.
But I cannot find any .dll files in there to copy them to the LastEpoch folder.

EDIT: I found my fault. I downloaded the ‘dxvk-1.7.zip’ and NOT the correct ‘dxvk-1.7.tar.gz’.
Now I can the the .dll and copied them to the game folder. Hope this will fix it.

Ill try this out as well. Im in the same boat. I couldnt find the dll files.

Yeah for the life of me I cannot find those dxgi.dll files. I downloaded the folders and the dxvk file that was 7mbs but I still cant find those files I am suppose to copy.