My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Game Crashes every time scene changes

This has become an issue lately and is making the game unplayable for me.

DxDiag.zip (14.2 KB)
Crash.zip (285.1 KB)

Attached is my system config .zip file, and the logs for the crash folder for your convenience.

The issue occurs when I load into a new area. Sometimes when I first boot up the game and it drops me in, instant freeze, and crash. Other times it’s when I teleport to another area. It always happens just as I am loading into another area. I have the settings maxed out and all my video drivers are up to date. My system can handle anything at insanity settings so I don’t believe the issue is on my end hardware-wise.

If this is the incorrect place to report such things, will a mod please forward this to the correct area for a response and clarification. I really appreciate it.

Other than the crashing, I was having quite a good time with the game. Hoping this can be resolved.

-J

Sorry about this! You’ve posted this thread in the right section, no worries.

Unfortunately I don’t have any specific guidance to offer at this point. You can try repairing the game through Steam if you haven’t already.

A few other people have reported similar issues and we’re working on a fix. However, the log files you provided have different information than those other people, so the fix likely won’t apply here.

We’ll be monitoring for other reports of this and will look into it as we can.