My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Excessive ram usage caused a crash

Summary

I had the game crash because of excessive ram usage, and I’ve documented my RAM, CPU and GPU usage in various states of the game.

So I had the game crash because it overflowed my ram and my system just hung until the game stopped running. When I ran the game again, I found that all of the progress I had made until the crash was lost. So the game doesn’t auto-save, like, ever? Not even on zone changes or after an hour timer or something? I guess it’s based off the assumption that the game is always going to be syncing with some server or other in the future, but still.

Anyhow, I went and hunted for other users who might’ve run into issues like this before, and I found a couple of threads on the forum that did not really address the issue. So I took a bunch of screenshots of the happenings on my computer before I launched the game through Steam, during the launch, and after the launch while I’m in the Council Chamber.

Before launching the game - CPU:

Before launching the game - GPU:
–removed because new users are limited to 5 images/links–

During loading - CPU:

During loading - GPU:

Just after launch - CPU:

Just after launch - GPU:

I also tried looking for a log file to include in this post, but all that I found was an empty log file that must’ve been generated when I was able to run the game and close it, because I avoided doing too many zone changes before rebooting the game.

I may want to mention that I’m running an AMD FX-8350, a GTX 1060 3GB and 16 GB of ram with a Debian GNU/Linux bullseye/sid OS, which is well above the recommended specs for this game.

Hi Garrosh, welcome to the community. This is good data, thank you for collecting it all. The game does auto-save very frequently but we do have a bug right now that causes those saves to become corrupted on crash. We are planning to release a fix for this problem with the next patch. I’m sorry for the inconvenience.

Thank you for your reply, Mike. Also, thank you for addressing my concern about auto-saves. But if I understand correctly what you’re saying, it means that I wouldn’t just lose my sessions’ work if the game crashes, but the whole save would be corrupt? Ouch. I guess I’ll have to keep a close watch on my RAM while I play, so I don’t crash the game by accident.

Also, you did not mention anything about ram usage, which was the main reason for my post. I would’ve liked some form of confirmation that the way the game is behaving on my computer isn’t standard behavior, or that you just forgot to update the minimum system requirements or anything else, to help me make a decision about the game.

Obviously I haven’t given up on the game, or I wouldn’t be here doing my best to give you useful information about a situation that could be improved, and I am more than willing to supply you with any and all information you may require to reproduce this behavior, but I do need some acknowledgment.

High memory usage/resource consumption is something other linux users (including myself) have been experiencing as well (e.g. Game won't launch (Linux), a report on the protondb page).