My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Critical graphical glitches all the time all over the places

With all due respect, these sort of bugs are not acceptable even in beta state, it’s literally not playable, that should be priority 1 on your worklist. I’ve seen many people posted this type of bug already.

It does not matter what settings I’m using, lowest possible, highest possible, whatever resolution, I also won’t believe in the type of excuse like “people have many different hardware specs”, it’s hard to reproduce etc. I’ll tell you that anyways, 1070Ti 442.59 Drivers (also tried newest 445.75), Ryzen 5 3600, SSD, 16GB RAM. The fact that some people defend it and accept it by saying it’s beta, just restart the game is beyoned me as well. I can tolerate some minor bugs here and there, missing features, but we’re talking about what you see on the screen, there’s literally just no way I could promote my product having such issues, it would be the exact opposite, I would be ashamed of having that even in the early prototype and do my best to fix it asap.

Got the same problems, seems to originating from enemies for me mostly, they die and its gone. Sometimes from objects too.
Really annoying indeed!

Dude i got the same problems, for me seems to originating from objects and light effects.-

Really annoying!

Having this issue also, tried capturing a screenshot but couldnt get one.

Ryzen 7 2700x
GTX1060 6gb
16gb ram

I found this issue especially using the soul skill on necromancer and in tight spaces.

Which soul skill are you referring to? I suspect it is related to a specific component on some skills. We can see the skills that OP has equipped, is it one of those?

The skill is Hungering Souls.

This is a recroding of the graphic glitches in gameplay, the video is 3 mins long and the glitches happen a few times very briefly, not as bad as the other the day when i was playing but still there.
Graphic Glitches
Player.log (144.9 KB)
DxDiag.txt (86.6 KB)

I was noticing a lot of this with my Skeletal Mages spells. Was a shame too was really enjoying the class but had to stop due to not being able to see. Just looked at the screen shots I took while this was happening and the screen shots look just fine.

Skill does not matter, as I have originally written it happens all the time after 10 minutes of game, more or less, outdoors, indoors does not matter, regardless the class, regardless items, regardless every single thing. It’s some fundamental bug so I’m not buying things like it’s hard to reproduce at all.

I already gave up on the game after few hours with it because it’s a joke (just to be clear in my opinon) in many departments if not all. It’s alpha not beta as it is advertised by the way. I wish that this time I had done my homework and checked the team members profiles on LinkedIn, that alone speaks for itself, based on that they have literally almost no experience in any software development not even game industry, unless their profiles lie which I don’t believe. I’m talking in general, any software engineering, or even education (apart from getting some Unity certificate), so wouldn’t be suprised by the state of that game. I’m not hating on them, everyone is blacksmith of his/her fate, everyone needs to start somewhere, but this is cruel nowadays, you can sell anything being anybody out of the blue, while at the same time not being transparent and naming things like they really are and not pretending how they are not. Don’t repeat my mistake and do some research in that department and only then decide whether to invest or not. Of course there are many delusional, desperate & for some reason blind believers that will hate on me for that opinion. I’m fine with that, with all due respect. You can always throw your spare money and make your own opinion.

Having that said I decided to report that critical and gamebreaking thing for the sake of the rest who hesitate to buy the so called beta product, even though there were already several similar issues reported here that nobody cares at all.

Sorry, but … WTF??? That’s not a Feedback, that’s only offence.

It’s true, there are bugs, glitches and performance problems. But I’ve played many betas, and I must say, this game is - beside some problems - in a really good state compared to most of the other betas.
And what shall I say: It’s a BETA and EARLY ACCESS and not the RELEASE!

btw, I can understand your Frustation, when I see your Screenshot.

That’s the thing though, it’s not happening to everyone, for most people, they do only get minor bugs here & there. If that’s happening to you all the time then that’s unplayable.

I am also getting graphical issues while running an RTX2070, Ryzen 7 2700x and 32GB RAM. I run most games on maximum (ultra) settings with no problems, but this game kills my PC! After only a few minutes of play my graphics card will be up to over 60 degrees Celsius. Something in the programming is drawing major power from the graphics requirements, even if I set the graphics to low. After about 40 minutes of play, the graphics start to have issues with “green” colours. Similar to Huey82 comments, it mainly comes from skeletal mages, poison etc. Other characters like my sentinel don’t get the issues as much, but it does still happen.

This is major shame as I am really enjoying the game, but I’m worried it’s going to kill my PC lol

Hi Ferriun, sorry you’re having issues with this. We appreciate the report and are working to solve this issue as soon as we can. I hope I can put your mind at ease about the temperature though. Graphics cards are designed to run at much higher temperatures than 60 degrees C, so if you’re still in that range you aren’t in any danger of damaging your card from the heat. I know it’s probably way hotter than most games and we’re working to reduce that.

I gave this article a quick skim and it looks to be pretty good if you’re looking for more in depth reading. It’s a couple years old but not much has changed in this regard in the last 5 years. https://www.cputemper.com/ideal-gpu-temperature-range/

Hey Mike, thanks for the feedback, much appreciated.

I thought the temperature might be relevant as my graphic issues only occur after a period of continuous play. I guess this isn’t the case. Keep up the good work with Last Epoch!

1 Like

Another recording of the graphics glitch, this time the skill was glacier, as you can probably tell, nothing has changed in terms of system from my previous post, so not really much point in me uploading the logs again. Certainly not as bad as it was using hungering souls, but hopefully you get to the bottom of it soon.