My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Crash on Enter Game

I have recently wanted to get back into the game after building a new PC. Everything is loaded and updated. Game launches fine, but when I select a character and click enter game, it crashes. Have tried on different graphical settings including fullscreen, windowed fullscreen, windowed mode, etc. Logs attached.

Win 10 64
i7-9700K (3.60 GHz)
16 GB RAM
GeForce RTX 2070 Super

output_log.txt (24.5 KB) Player.log (8.4 KB) Player-prev.log (29.1 KB) version.txt (11 Bytes)

Sorry to hear you’re having this issue! Please try to repair the game through Steam.

If that doesn’t help, please add any files in C:/Users/YOURNAME/AppData/Local/Temp/Eleventh Hour Games/Last Epoch/Crashes to a .zip file and upload them here so we can look into this.

Thanks, the repair fixed it. I never even thought about that after a fresh install.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.