My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Crafting items higher than you can use

Is it a bug that it requires level 32 to forge it, but the item now requires level 44 to actually equip it? It seems like it would be better that you can’t craft items that you can’t wear. Also, it doesn’t show in the tooltip what level the item will become, which would be REALLY helpful if this isn’t a bug.

Thank you for the report! This is indeed a bug.

If you haven’t opened your game client again since this occurred, could you please post your log file? This file is wiped each time the game client is started.

https://support.lastepochgame.com/article/39-the-games-log-file

output_log.txt (645.7 KB)

Thanks!

This issue should be resolved in our next patch.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.