My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Conduit node on Enchant Weapon from Spellblade is still not working

I activate Enchant Weapon and run around right next to enemies and there is no Zap happening, this was apparently an issue back a year ago and was apparently fixed in a patch back then as well, but seems to still be an issue now. Any idea if this can be fixed soon? Or should I just cut my losses and spend my points elsewhere?

Hey… I can confirm that Zap is working. I have Conduit and Thundering and its procing a zap on the dummy as expected… Maybe there is something more specific that is causing your problem? Does it work on the dummy for you?

Does not work on Dummy, I did not have the frequency increasing node (Thundering) yet, I tried standing right next to both the Dummy and other enemies and activating Enchant Weapon and no Zaps happen, which is not what should be happening.

Zaps from my Discharge are happening all the time, but the Enchant Weapon - Conduit - Zaps are not working at all.

Here are my Enchant settings & a screenshot of the zap on the dummy…

Not sure if it will help you… Might need a dev to look into this.

I’ve tested this and found that Conduit does not work until you have taken at least one point in Thundering. We’ll look into a fix.

Thanks for the report!

2 Likes

I had just discovered this myself, thanks for the response! I’m definitely putting points in Thundering anyway, so it’ll be fine for now, but thanks in advance for the fix when it happens :slight_smile:

Your input was very helpful, thanks for that! Put my first point in Thundering and watched the Zaps happen and was delighted :blush:, thanks for the workaround!

1 Like