My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Can't complete Mono

I’m having trouble completing Fall of the Outcast Mono.

Here is my log file.
Player.log (3.9 MB)

I had a similar issue. Once i opened up the next level tier (68), i did a monolith that was the lvl 55 tier and could not complete it. I ended up porting out and just went to the next tier. Not sure if its related.

To avoid starting another post of this exact thing, I’m going to piggy back on this post. I also cannot complete Fall of the Outcast on my sorcerer. No credit is given after completing the objective “Destroy the Bones of the Outcasts.” Contrary to EasyPZ’s post, porting out doesn’t do anything to further my progress and I’m unable to go on to the next tier as it remains locked.

FIX: You must kill the Bones in melee range (be inside the green circle).

Worked for my Bear druid the first time, the only factor between him and my mage is melee vs ranged. Went back on my mage and teleported into the green circle before killing it, and Bob’s your uncle.

Sorry about this! I haven’t been able to narrow down the cause of this issue yet. The quest completes as expected for the majority of the time.

To help narrow this down, anyone who has encountered this issue should attach their log file and ideally a screenshot.

Additionally, if you can remember any modifiers that the Bones of the Outcasts enemy had (i.e. from Monolith mods that apply to all enemies), please list them. Thanks!

Unfortunately I haven’t found any correlation between how far away you are. I was able to complete the quest both in and out of the circle.

I died 4x already…its a pain with a summoner(ranged)build and imo not the best game mechanic. If you need to respec it would suck…i dont have any melee pets (golem only).

finally completed can be done but mehhhhh for ranged .

Well, may be I was doing something wrong but when I tried to destroy that totem on range distance using storm totem, ice thorns and shaman’s channel skill I wasn’t able to destroy it. I’m not sure if bones totem got any damage or it was able to heal it when I was fighting with summoned undeads.

Well, tried one more time and was able to destroy the totems. I stayed in green circle and blow by blow destroyed it. It takes time but maybe due to low damage and monolith mods.