My Account
× My Account Media Forum Supporter Packs

Cannot update - Failed to connect to the patchKit API

launcher

#1

2019-05-16%2003_29_40-CN%3DMicrosoft%20Windows%2C%20O%3DMicrosoft%20Corporation%2C%20L%3DRedmond%2C%20S%3DWashington%2C%20C%3DUS

As can be seen from above, I cannot update or install the game. The launcher couldn’t pass the initializing phase when the 0.7e patch came, so I uninstalled it and tried to download when the 0.7f patch released. But now I can’t even download and install the game.

Before anyone asks, yes there is no problem with my internet connection, firewall permissions are ok too.


#2

Hey there, could you post the log files from the Launcher?

https://support.lastepochgame.com/article/108-the-launchers-log-files

You should be able to click the upload button and attach them to a post.


#3

launcher-log.txt (11.6 KB)


#4

Thanks.

This coincides with us using a new version of the launcher, so I’m asking around to see if this is something that has come up during internal testing. I’ll report back after getting a response.

If you’ll forgive me for saying, this is the first report I’ve seen about it - and searching our forum isn’t turning up any others - so it wouldn’t hurt to continue going through the usual suspects (e.g. right-click & select Run as Administrator since you’re on Windows). We’ll look into it on our end, but the more efforts being made to figure it out, the sooner we will. :slight_smile:


#5

Could you please try visiting this page and let us know if you see anything?

https://api2.patchkit.net/1/apps/7bc4f49fcabe004069788293d85d5e56/versions/latest/id


#6

{“id”:16}

what is on the screen. Thats all.


split this topic #7

2 posts were split to a new topic: Game client is crashing on startup


#9

This is what I see when visiting the page;

@cgtyky is posting a specific error message, which @Liquidcyanide doesn’t seem to be getting. I’m going to separate these posts into different threads as a result.

Can I ask (both of you) whether you’re using a proxy or VPN?
 

Edit: Liquidcyanide appears to be a Steam user for whom the game client is crashing on startup. CGTYKY is using the standalone client and getting an error message from our launcher. Steam users don’t have this program installed, so these issues are unrelated.


#10

I am not using a VPN or proxy. I used to have DNS setting which was cloudflare DNS 1.1.1.1 but I reversed that setting to my ISP DNS but nothing changed.


#11

I think I managed to solve this problem. Reset my Internet Explorer settings resolved this problem. Even if you don’t use Internet Explorer (I am using Chrome) you have to this.
Go to your Control Panel -> Network and Internet -> Internet Options -> Advanced -> Reset -> Reset -> OK

After this restart your launcher and it will work. At least mine did.


closed #12

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.