My Account
× My Account Media Forum Supporter Packs

Boost FPS - possible fix


#1

I provided some false information, so i will edit my post and provide new possible solutions for FPS fix.

  1. Reinstall the game - you can try to install on another disk if you will still get fps drops, you get to keep you character progression btw as long you install game on same pc, the save data gets stored in windows registry

  2. Open Settings go to Graphics and set shadows auality to low

  3. Open Settings go to Advanced graphics and

    set memory allocation to Dynamic

OR ! :exclamation:

set memory allocation to Certain X amount

Beware !

Go to google and check how much your vRam you grahpic card has !

 set render mode** to **Forward**
  1. If you are using Steam to play LE, go to library, look for Last Epoch, right click on it, go to properties and disable Steam overlay

Also, dont forget to update your windows and graphic card drivers

This next step provided me much less FPS drops, but do this at your own risk.
( in theory this should not harm your PC in any way )

  • Disable Microsoft Store (win10)

The simplest way to disable the Store is using Group Policy: open the Local Group Policy Editor and go to Computer Configuration -> Administrative Templates -> Windows Components -> Store ; in the Settings pane on the right, double click Turn off Store application , select Enabled in the properties page for the policy and click OK .

In Windows 10 you could disable the Microsoft STORE app using the Local Group Policy editor:

  1. click START, type GPEDIT.MSC and press the Enter key
  2. Expand USER CONFIGURATION > ADMINISTRATIVE TEMPLATES > WINDOWS COMPONENTS > STORE
  3. Set TURN OFF THE STORE APPLICATION
  4. Click START, type REGEDIT.EXE and press ENTER Key
  5. Expand KEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsStore
  6. Right click and select NEW > REG_DWORD
  7. Name it RemoveWindowsStore
  8. Set the value to 1
  9. Reboot the PC and notice that the store is locked
  10. Open PowerShell by typing PowerShell in your taskbar- Windows PowerShell ISE
  11. Type

Get-AppxPackage windowsstore | Remove-AppxPackage

And press Enter

Reboot your PC again.

Source ( with images ) :
https://social.technet.microsoft.com/Forums/Lync/en-US/a8405957-5025-427e-9405-331b1a8dde21/uninstall-or-disable-the-microsoft-store?forum=win10itprogeneral

Nvidia grahpic cars owners:

  1. Open Nvidia Control panel

  2. Under 3D settings look for Manage 3D settings and open it

  3. Go to program settings next to global settings.

  4. Add Last Epoch.exe File, located in your steam library game installation file.

( usually located in C:\Program Files (x86)\Steam\steamapps\common\Last Epoch, if you cant find it open Steam, go to libraly, seach for Last Epoch, right click it, go to properties, local files, and click browse local files )

  1. Once you add Last Epoch.exe to the list,
    scroll down to power management and set it to

Prefer Maximum performance

  1. Scroll down again and look for
    Texture filtering - Quality
    and set it to
    High performance

Click apply

If you care more about your fps in all your games, and dont care about graphics that much you can change global settings in Nvidia control panel
by changing to ** performance ** when you select ** Use my preference emphasizing**

Reboot your PC.


#2

Set it to dynamic actually.
I talked to developer and he told me Dynamic is how it should be.


#3

Set render mode to:

Vertexlit


#4

Dynamic will just automatically choose the best setting for you, Vertexlit will indeed improve performance but will lessen quality.


#5

I tried to reinstall my game and it worked,
My FPS is way better atm.

I also edited my post, since i was wrong.


#6

Reinstalling, and trying it out.
Thanks. :slight_smile:

Edit: Says I have 8192 Dedicated Video Memory, will 819"6" overkill it, due to 4MB off…?
Like… wow. Haha, never know…
Think it has just gotten worse since the previous patch, I actually wasn’t have too hard of a time with FPS issues, more of sound tares, and lag spikes primarily, but my FPS is trash since the latest patch. FPS tracker top right won’t even appear since I re-installed. o_o
Not sure what’s going on, game needs proper fixes.


#7

I found out that manually setting Memory Allocation [GPU] can boost ur FPS and make it
somewhat stable-ish.
I set mine to 8196 mb
Make you google how much vRam your graphic card has first !


#8

This next step provided me much less FPS drops, but do this at your own risk.
( in theory this should not harm your PC in any way )

  • Disable Microsoft Store (win10)

The simplest way to disable the Store is using Group Policy: open the Local Group Policy Editor and go to Computer Configuration -> Administrative Templates -> Windows Components -> Store ; in the Settings pane on the right, double click Turn off Store application , select Enabled in the properties page for the policy and click OK .

In Windows 10 you could disable the Microsoft STORE app using the Local Group Policy editor:

  1. click START, type GPEDIT.MSC and press the Enter key

  2. Expand USER CONFIGURATION > ADMINISTRATIVE TEMPLATES > WINDOWS COMPONENTS > STORE

  3. Set TURN OFF THE STORE APPLICATION

  4. Click START, type REGEDIT.EXE and press ENTER Key

  5. Expand KEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsStore

  6. Right click and select NEW > REG_DWORDblock-windows-store

  7. Name it RemoveWindowsStore

  8. Set the value to 1

  9. Reboot the PC and notice that the store is locked

  10. Open PowerShell by typing PowerShell in your taskbar- Windows PowerShell ISE

  11. Type

Get-AppxPackage windowsstore | Remove-AppxPackage

And press Enter

Reboot your PC

Source ( with images ) :
https://social.technet.microsoft.com/Forums/Lync/en-US/a8405957-5025-427e-9405-331b1a8dde21/uninstall-or-disable-the-microsoft-store?forum=win10itprogeneral


#9

Nvidia grahpic cars owners:

  1. Open Nvidia Control panel

  2. Under 3D settings look for Manage 3D settings and open it

  3. Go to program settings next to global settings.

  4. Add Last Epoch.exe File, located in your steam library game installation file.

( usually located in C:\Program Files (x86)\Steam\steamapps\common\Last Epoch, if you cant find it open Steam, go to libraly, seach for Last Epoch, right click it, go to properties, local files, and click browse local files )

  1. Once you add Last Epoch.exe to the list,
    scroll down to power management and set it to

Prefer Maximum performance

  1. Scroll down again and look for
    Texture filtering - Quality
    and set it to
    High performance

Click apply

If you care more about your fps in all your games, and dont care about graphics that much you can change global settings in Nvidia control panel
by changing to ** performance ** when you select ** Use my preference emphasizing**

Reboot your PC.


#10

:thinking:


#11

@GlowSticks
Did this help improve your FPS ?


#12

I’m undergoing testing it out right now to see… Firstly doing the nvidia specific settings first, then will try disabling the store, I don’t need the store.

Will edit this post as I test. So far it seems slightly better, but can’t say for sure yet, it’s really certain maps for me that I have issues with, and in arena. Will take some time. ~_~

Do you recommend doing all the settings, or tinkering with a few, and seeing what helps first?
Some-what lost.

Just ran Lagonian Port map, still runs the same. The entire map is a huge FPS drop for me. Will try the store next.

Yeah, gpedit.msc is not defaulted on my computer anywhere. Tried to run it, search it, etc. not found.

Huge Cumulative Update for Windows 10 (2019-05) doing that right now. >_>

Yeah, I as well get that same shuttering lag with a lot of mobs grouped up. My biggest annoyance is the certain map layouts run really bad FPS wise. (Any Forest map, such as shrine, burning forest, etc. Sometimes Desert, Lagonian Port is the worst. Any other map is fine)


#13

Yea, this reduced my FPS drops by a small amount, but i dont get many shuttering where my game would freeze up every few seconds. It is less frustrating, but it’s something.

As for setting goes, you could try changing other settings yourself. If you don’t know what exactly they mean, google it.


#14

hey, all I wanted to clear up some of the ambiguity and lack of information on my part :wink:
first of I just wanted to let u lot know that if you’re having any weird issues feel free to get in contact with me about it. anyway into it :wink:

memory allocation
memory allocation is how much vram can be dedicated to the texture streaming system. so for example if your graphics card has 2GB and the memory allocation is set to dynamic the game will get that graphics card memory. as a safety measure, the dynamic system is always 256mb less than the total vram u have. as of such, we have given u the option to manually select a higher vram amount. (disregarding the -256mb safety) this way if u know what your vram is u can set it and not run into weird issues. when the vram does run out the system will attempt to use shared memory (system ram). if u want to get a performance boost instead of touching the memory allocation u want to adjust the texture quality dropdown.

render mode

Deferred Shading

Deferred Shading is the rendering path with the most lighting and shadow fidelity, and is best for all the realtime lights in le

Forward Rendering

Forward is the traditional rendering path. It supports all the typical Unity graphics features (normal maps, per-pixel lights, shadows etc.). However, under default settings, only a small number of the brightest lights are rendered in per-pixel lighting mode. The rest of the lights are calculated at object vertices or per-object.

Legacy Vertex Lit

Legacy Vertex Lit is the rendering path with the lowest lighting fidelity and no support for real-time shadows.

future
in the future, I will be adding tips for each graphical option to help out with all of this.