My Account
× My Account Media Forum Supporter Packs

Beta Client Issue: Please Check Your Internet Connection


I’ve added all files for Last Epoch to window’s firewall exceptions list and I’m definitely connected to the Internet (typing from the exact same PC).

error message

Any ideas why the client wouldn’t choose to work?

Edit: I’ve also run this from an elevated (e.g. Administrator) account as well.

Edit #2: Uninstalled and reinstalled from elevated privileges. Still no connection to Server (mirrors the same). Launcher sits at 0.0% endlessly.

endless load

Note: this is NOT a Steam Install. This download was done through my account panel as I’m a supporter.




Hmmm… already tried to run the launcher as administrator? If it isn’t allowed to write files that might be a problem… otherwise I don’t know… have you written the support via mail? After 8 days, I’d call it fair game to do so

closed #4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.