My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

Alpha launcher

I just returned from work, I tried to link my account with steam and im getting an error, even when it goes through it still says my account isnt linked? Am I able to just use my alpha launcher or will that launcher not update to the Beta?

You should be able to use the alpha launcher. But I believe the devs are facing some technical issues atm.

Tried using the alpha launcher and it tells me that I don’t have access to the beta and that I need to try using the steam Link

@zythron Sorry about that! If you try this again now it should work properly.

@Huntedknight Has somebody already helped you with this? Are you using the Steam client or the standalone client? From what I can see it should be working for you now.

Same here. Can’t link to Steam, and launcher tells me I don’t have access to beta. Going to bed now. Hopefully will at least get Steam code tomorrow. :frowning:

Direct quote from Discord:

@here We have a likely fix for those of you that are affected by the “blank steam key” page.

Send an email to support@lastepochgame.com with the subject line “blank steam key” and include the email address your Last Epoch account was registered with

I have the same problem.

Alpha access, alpha client (patched), no beta access, can’t link with steam.

I’ve sent an email last night regarding this, no reply

Yup My account is good now

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.