My Account
× My Account Media Forum Supporter Packs

Last Epoch Forums

4k resolution fps weirdness

It takes me a ton of messing around to finally get the game into 4k,when I do the frames completely tank down to 24-27,I turn graphics too very low,game is still in 4 k but frames seems locked at 30 fps.
I have a 1070 video card,when im playing out of 4k,not sure what resolution it is cause settings set at 4k but its not 4 k My fps lock too 60 fps,when I change some thing in adv graphics area like deph of field it totally borks everything again in ways that just changing that shouldnt.

 There is a whole lotta messed up in the resolution/graphics settings in this game that need to be dealth with ASAP cause it either looks horrible or plays horrible currently,for me anyway if any have suggestions how to fix it pls speak up.

Any suggestions on how to fix it is most appreciated.

I am also having fps problems on wide screen 3440x1440 on my RTX 2080, it seems though a lot of people are as well with different setups, looks like we will have to wait for more optimization, as currently there’s not much we can do from our side to fix the fps lag we are getting

Honestly, you should be sticking to 1080p with a 1070.
Even with a 2080 ti at 4k you will get frame drops (with everything set to low) due to the game being in Beta and not being very optimised right now.

With that being said, the biggest fps hits i found are due to Shadows and AO.

This game as it is does not like 4K a lot but you can get it working if you set it up at each launch.

After the game has launched and you have logged in, select settings/graphics and drop the screen resolution lower than the one you want and then back up to the one you want. This will make the game display the correct resolution.

Once you have the game running in 4K turn off vsync as this seems to lock the game at 30 FPS. AA and shadows are also worth turning right down as these hog FPS in 4K for a beta game like this.

Next go to advanced graphics and uncheck Grain. Also set Memory Allocation(GPU) to a higher amount for your GPU.

If you still have issues, restart the game and go back to advanced graphics and uncheck things on the right hand side until you get the game to run smoothly.

Be aware that each time you run the game you must go into graphics settings and drop-then-increase the screen resolution to make it display in 4K.

Ty so much for advice ill try that,had vsync on mabe that was alot of the prob,game looks better in 4k on very low than 1080 at ultra on a 55 inch 4k tv.

Either way, no matter what you do, the performance will never be great at 4k for you.
I’ve tested with a 2080 ti @ 4k with everything on low and just about manage 60fps & still get the occasional fps drops & micro stutter.
Considering a 2080 ti is over 100% more powerful than a 1070, that should tell you everything you need to know.
I do have a 1070 ti and 1080 ti laying around though, i may do some benchmarks this weekend with those cards at 4k & post back those results.

It was definatly the vsync,disabled it did what ya said to lower then return to old resolution and it worked,turned most graphics options off kept texture quality high and am hovering around 42-46 fps,not great but I can live with it till hopefully they figure out there optimization issues.
Givin my 55 inch TV as a monitor 40 plus frames is better than real blurry stretched out visuals at 75 fps.
TY again for reply/help.

You could always play at a lower setting to get higher fps and use ReShade to counter the blurry screen by injecting Lumasharpening.

Not sure what reshade is,the blurry problem stems more from a large screen surface on 55inch at lower resolution than anything,not sure anything other than higher resolution fixes that.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.